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Maintaining a Database



Objectives

• Add, change, and delete records

• Search for records

• Filter records

• Update a table design

• Format a datasheet

• Use action queries to update records
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Objectives

• Specify validation rules, default values, and 
formats

• Create and use single-valued and multivalued
Lookup fields

• Specify referential integrity

• Use a subdatasheet

• Sort records
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Plan Ahead

• Determine when it is necessary to add, change, or 
delete records in a database

• Determine whether you should filter records
• Determine whether additional fields are necessary 

or whether existing fields should be deleted
• Determine whether validation rules, default values, 

and formats are necessary
• Determine whether changes to the format of a 

datasheet are desirable
• Identify related tables in order to implement 

relationships between the tables
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Starting Access

• Click the Start button on the Windows Vista taskbar 
to display the Start menu

• Click All Programs at the bottom of the left Pane on 
the Start menu to display the All Programs list and 
then click Microsoft Office in the All Programs list to 
display the Microsoft Office list

• Click Microsoft Office Access 2007 on the Microsoft 
Office list to start Access and display the Getting 
Started with Microsoft Office Access window

• If the Access window is not maximized, click the 
Maximize button on its title bar to maximize the 
window
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Opening a Database

• With your USB flash drive connected to one of the 
computer’s USB ports, click the More button to 
display the Open dialog box

• If the Folders list is displayed below the Folders 
button, click the Folders button to remove the 
Folders list

• If necessary, click Computer in the Favorite Links 
section and then double-click UDISK 2.0 (E:) to select 
the USB flash drive, as the new open location. (Your 
drive letter might be different.)

• Click JSP Recruiters to select the file name
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Opening a Database

• Click the Open button to open the database

• If a Security Warning appears, click the Options 
button to display the Microsoft Office Security 
Options dialog box

• Click the Enable this content option button

• Click the OK button to enable the content
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Creating a Simple Form

• Show the Navigation pane if it is currently hidden

• If necessary, click the Client table in the 
Navigation pane to select it

• Click Create on the Ribbon to display the Create 
tab

• Click the Form button on the Create tab to create 
a simple form

• Click the Form View button to display the form in 
Form view
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Creating a Simple Form
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Using a Form to Add Records

• Click the New (blank) record button on the 
Navigation bar to enter a new record, and then type 
the data  for the new record as shown on the 
following slide. Press the TAB key after typing the 
data in each field, except after typing the data for 
the final field (Recruiter Number)

• Press the TAB key to complete the entry of the 
record

• Click the Close ‘Client’ button to close the Client 
form

• Click the No button when asked if you want to save 
your changes
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Using a Form to Add Records

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 11



Searching for a Record

• Right-click Client Form in the Navigation pane and 
click Open on the shortcut menu to open the form in 
Form view

• Hide the Navigation pane
• Click the Find button on the Home tab to display the 

Find and Replace dialog box
• Type MH56 in the Find What text box
• Click the Find Next button in the Find and Replace 

dialog box to find client MH56
• Click the Cancel button in the Find and Replace 

dialog box to remove the dialog box from the screen
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Searching for a Record
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Updating the Contents of a Record

• Click in the Client Name field in the datasheet for 
client MH56 after the letter M to select the field

• Press the DELETE key twice to delete the letters 
au

• Type the letters un after the letter M

• Press the TAB key to complete the change and 
move to the next field
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Updating the Contents of a Record
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Deleting a Record

• With the Client Form open, click the record 
selector in the datasheet (the small box that 
appears to the left of the first field) of the record 
on which the client number is EA45

• Press the DELETE key to delete the record

• Click the Yes button to complete the deletion

• Close the Client Form by clicking the Close ‘Client 
Form’ button

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 16



Deleting a Record
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Using Filter By Selection

• Open the Client form and hide the Navigation 
pane

• Click the City field on the first record in the 
datasheet portion of the form to select Berridge
as the city

• Click the Selection button on the Home tab to 
display the Selection menu

• Click Equals “Berridge” to select only those 
clients whose city is Berridge
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Using Filter By Selection
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Toggling a Filter

• Click the Toggle Filter button on the Home tab to 
toggle the filter and redisplay all records
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Using a Common Filter

• Be sure the Home tab is selected

• Click the City arrow to display the common filter 
menu

• Point to the Text Filters command to display the 
custom text filters

• Click Begins With to display the Custom Filter 
dialog box
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Using a Common Filter

• Type Ber as the City begins with value

• Click the OK button to filter the records

• Click the Toggle Filter button on the Home tab to 
toggle the filter and redisplay all records
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Using a Common Filter
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Using Filter By Form

• Click the Advanced button on the Home tab to 
display the Advanced menu

• Click Clear All Filters on the Advanced menu to 
clear the existing filter

• Click the Advanced button on the Home tab to 
display the Advanced menu a second time

• Click Filter By Form on the Advanced menu
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Using Filter By Form

• Click the Postal Code field, click the arrow that 
appears, and then click 80330

• Click the Amount Paid field, click the arrow that 
appears, and then click 0

• Click the Toggle Filter button on the Home tab to 
apply the filter
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Using Filter By Form
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Using Advanced Filter/Sort

• Click the Advanced button on the Home tab to 
display the Advanced menu, and then click Clear All 
Filters on the Advanced menu to clear the existing 
filter

• Click the Advanced button on the Home tab to 
display the Advanced menu a second time

• Click Advanced Filter/Sort on the Advanced menu
• Expand the size of the field list so all the fields in the 

Client Table appear
• Include the Client Number field and select 

Ascending as the sort order
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Using Advanced Filter/Sort

• Include the Postal Code field and enter 80330 as 
the criterion

• Include the Amount Paid field and enter 0 as the 
criterion in the Criteria row and >20000 as the 
criterion in the Or row

• Click the Toggle Filter button on the Home tab to 
toggle the filter and view the results. Click the Client 
Form tab to view the Client table

• Click Clear All Filters on the Advanced menu

• Close the Client Form
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Using Advanced Filter/Sort
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Adding a New Field

• Show the Navigation pane, and then right-click the 
Client table to display a shortcut menu

• Click Design View on the shortcut menu to open the 
Client table in Design view

• Click the row selector for the Amount Paid field, and 
then press the INSERT key to insert a blank row 
above the Amount Paid row

• Click the Field Name column for the new field. If  
necessary, erase any text that appears

• Type Client Type as the field name and then 
press the TAB key
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Adding a New Field
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Creating a Lookup Field

• If necessary, click the Data Type column for the Client Type 
field, and then click the arrow to display the menu of 
available data types

• Click Lookup Wizard, and then click the ‘I will type in the 
values that I want.’ option button to indicate that you will 
type in the values

• Click the Next button to display the next Lookup Wizard 
screen

• Click the first row of the table (below Col1), and then type 
MED as the value in the first row

• Press the DOWN ARROW key, and then type DNT as the 
value in the second row
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Creating a Lookup Field

• Press the DOWN ARROW key, and then type LAB
as the value in the third row

• Click the Next button to display the next Lookup 
Wizard screen

• Ensure Client Type is entered as the label for the 
lookup column and that the Allow Multiple 
Values check box is NOT checked

• Click the Finish button to complete the definition 
of the Lookup Wizard field
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Creating a Lookup Field
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Adding a Multivalued Field

• Click the row selector for the Amount Paid field, and then press 
the INSERT key to insert a blank row

• Click the Field Name column for the new field, type 
Specialties Needed as the field name, and then press 
the DOWN ARROW key

• Click the Data Type column for the Specialties Needed field, 
and then click Lookup Wizard in the menu of available data 
types to start the Lookup Wizard

• Click the ‘I will type in the values that I want.’ option button to 
indicate that you will type in the values

• Click the Next button to display the next Lookup Wizard screen
• Click the first row of the table (below Col1), and then type CLS

as the value in the first row
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Adding a Multivalued Field

• Enter the remaining values from the first column in 
Table 3–1 on page AC 160. Before typing each value, 
press the TAB key to move to a new row

• Click the Next button to display the next Lookup 
Wizard screen

• Ensure Specialties Needed is entered as the label for 
the lookup column

• Click the Allow Multiple Values check box to allow 
multiple values

• Click the Finish button to complete the definition of 
the Lookup Wizard field
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Saving the Changes and Closing the Table

• Click the Save button on the Quick Access 
Toolbar to save the changes

• Click the Close ‘Client’ button
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Using an Updated Query

• Create a new query for the Client table

• Click the Update button on the Design tab, 
double-click the Client Type field to select the 
field, click the Update To row in the first column 
of the design grid, and then type MED as the 
new value

• Click the Run button on the Design tab to run the 
query and update the records

• Click the Yes button to make the changes
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Using an Updated Query
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Using a Delete Query

• Clear the grid

• Click the Delete button on the Design tab to 
make the query a Delete query

• Double-click the Postal Code field to select the 
field

• Click the Criteria row for the Postal Code field 
and type 80412 as the criterion
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Using a Delete Query

• Run the query by clicking the Run button

• Click the Yes button to complete the deletion

• Close the Query window. Do not save the query
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Specifying a Required Field

• Show the Navigation pane, and then open the 
Client table in Design view

• Select the Client Name field by clicking its row 
selector

• Click the Required property box in the Field 
Properties pane, and then click the down arrow 
that appears

• Click Yes in the list
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Specifying a Required Field
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Specifying a Range

• Select the Amount Paid field by clicking its row 
selector, click the Validation Rule property box to 
produce an insertion point, and then type >=0 
and <=100000 as the rule

• Click the Validation Text property box to produce 
an insertion point, and then type Must be at 
least $0.00 and at most $100,000

as the text
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Specifying a Range
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Specifying a Default Value

• Select the Client Type field. Click the Default 
Value property box to produce an insertion point, 
and then type =MED as the value

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 46



Specifying a Collection 
of Allowable Values
• Make sure the Client Type field is selected

• Click the Validation Rule property box to produce 
an insertion point and then type =MED or 
=DNT or =LAB as the validation rule

• Click the Validation Text property box and then 
type Must be MED, DNT, or LAB as the 
validation text
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Specifying a Collection 
of Allowable Values
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Specifying a Format

• Select the Client Number field

• Click the Format property box and then type >
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Saving the Validation Rules, Default 
Values, and Formats
• Click the Save button on the Quick Access 

Toolbar to save the changes

• Click the No button to save the changes without 
testing current data

• Close the Client table
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Saving the Validation Rules, Default 
Values, and Formats
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Using a Lookup Field

• Open the Client table in Datasheet view and 
ensure the Navigation pane is hidden

• Click in the Client Type field on the third record 
to display the arrow

• Click the down arrow to display the drop-down 
list of available choices for the Client Type field

• Click DNT to change the value

• In a similar fashion, change MED on the ninth 
record to LAB
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Using a Lookup Field
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Using a Multivalued Lookup Field

• Click the Specialties Needed field on the first record 
to display the arrow

• Click the arrow to display the list of available 
specialties

• Click the CNA, PA, Phy, and RN check boxes to select 
the specialties for the first client

• Click the OK button to complete the selection

• Using the same technique, enter the specialties 
given in Figure 3–47 on page AC 173 for the 
remaining clients
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Using a Multivalued Lookup Field
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Resizing a Column in a Datasheet

• Point to the right boundary of the field selector for the 
Specialties Needed field so that the mouse pointer becomes a 
doubled-ended arrow

• Double-click the right boundary of the field selector for the 
Specialties Needed field to resize the field so that it best fits 
the data

• Use the same technique to resize all the other fields to best fit 
the data. To resize the Amount Paid, Current Due, and 
Recruiter Number fields, you will  need to scroll the fields by 
clicking the right scroll arrow shown in Figure 3–52 on page AC 
175

• Save the changes to the layout by clicking the Save button on 
the Quick Access Toolbar

• Close the Client table
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Resizing a Column in a Datasheet
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Including Totals in a Datasheet

• Open the Recruiter table in Datasheet view and 
hide the Navigation pane

• Click the Totals button on the Home tab to 
include the Total row in the datasheet

• Click the Total row in the Commission column to 
display an arrow

• Click the arrow to display a menu of available 
computations
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Including Totals in a Datasheet

• Click Sum to calculate the sum of the 
commissions

• Click the Total row in the Rate column to display 
an arrow

• Click the arrow to display a menu of available 
computations

• Click Average to calculate the average of the 
rates
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Including Totals in a Datasheet
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Removing Totals from a Datasheet

• Click the Totals button on the Home tab to 
remove the Total row from the datasheet

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 61



Changing Gridlines in a Datasheet

• Open the Recruiter table in Datasheet view, if it is 
not already open

• Click the box in the upper-left corner of the 
Datasheet selector to select the entire datasheet

• Click the Gridlines button on the Home tab to 
display the Gridlines gallery

• Click the Gridlines: Horizontal command in the 
Gridlines gallery to include only horizontal 
gridlines
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Changing Gridlines in a Datasheet
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Changing the Colors and Font 
in a Datasheet
• With the datasheet for the Recruiter table selected, click 

the Alternate Fill/Back Color button arrow to display the 
color palette

• Click Aqua Blue (the second from the right color in the 
standard colors) to select aqua blue as the alternate color

• Click the Font Color arrow, and then click Red (the second 
color in the bottom row) in the lower-left corner of 
standard colors to select Red as the font color

• Click the Font box arrow, and then select Bodoni MT as the 
font. (If it is not available, select any font of your choice.)

• Click the Font Size box arrow and select 10 as the font size
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Changing the Colors and Font 
in a Datasheet
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Closing the Datasheet Without Saving 
the Format Changes
• Click the Close ‘Recruiter’ button to close the 

Recruiter table

• Click the No button in the Microsoft Office 
Access dialog box when asked if you want to save 
your changes

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 66



Querying a Multivalued Field Showing 
Multiple Values on a Single Row
• Create a query for the Client table and hide the 

Navigation pane

• Include the Client Number, Client Name, Client 
Type, and Specialties Needed fields

• View the results
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Querying a Multivalued Field Showing 
Multiple Values on a Single Row
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Querying a Multivalued Field Showing 
Multiple Values on Multiple Rows
• Return to Design view and ensure the Client Number, 

Client Name, Client Type, and Specialties Needed fields are 
selected

• Click the Specialties Needed field to produce an insertion 
point, and then type a period and the word Value after 
the word, Needed, to use the Value property

• View the results

• Close the query by clicking the Close ‘Query1’ button

• When asked if you want to save the query, click the No 
button
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Querying a Multivalued Field Showing 
Multiple Values on Multiple Rows

Microsoft Office 2007: Introductory Concepts and Techniques - Windows Vista Edition 70



Specifying Referential Integrity

• Click Database Tools on the Ribbon to display the 
Database Tools tab

• Click the Relationships button on the Database 
Tools tab to open the Relationships window and 
display the Show Table dialog box

• Click the Recruiter table and then click the Add 
button to add the Recruiter table

• Click the Client table and then click the Add 
button to add the Client table
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Specifying Referential Integrity

• Click the Close button in the Show Table dialog 
box to close the dialog box

• Resize the field lists that appear so all fields are 
visible

• Drag the Recruiter Number field in the Recruiter 
table field list to the Recruiter Number field in 
the Client table field list to open the Edit  
Relationships dialog box to create a relationship

• Click the Enforce Referential Integrity check box
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Specifying Referential Integrity

• Click the Cascade Update Related Fields check 
box

• Click the Create button to complete the creation 
of the relationship

• Click the Save button on the Quick Access 
Toolbar to save the relationship you created

• Close the Relationships window by clicking the 
Close ‘Relationships’ button
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Specifying Referential Integrity
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Using a Subdatasheet

• Open the Recruiter table and hide the Navigation 
pane

• Click the plus sign in front of the row for 
Recruiter 24 to display the subdatasheet

• Close the datasheet for the Recruiter table
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Using a Subdatasheet
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Using the Ascending Button 
to Order Records
• Open the Client table in Datasheet view and hide 

the Navigation pane

• Click the City field on the first record to select the 
field

• Click the Ascending button on the Home tab to 
sort the records by City

• Close the table. When asked if you want to save 
your changes, click the No button
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Using the Ascending Button 
to Order Records
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Quitting Access

• Click the Close button on the right side of the 
Access title bar to quit Access
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Summary

• Add, change, and delete records

• Search for records

• Filter records

• Update a table design

• Format a datasheet

• Use action queries to update records
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Summary

• Specify validation rules, default values, and 
formats

• Create and use single-valued and multivalued
Lookup fields

• Specify referential integrity

• Use a subdatasheet

• Sort records
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