
3/9/2010

1

Microsoft Office 2007

Excel Chapter 2

Formulas, Functions,
Formatting, and Web
Queries

Objectives

• Enter formulas using the keyboard and Point 
mode

• Apply the AVERAGE, MAX, and MIN functions

• Verify a formula using Range Finder

• Apply a theme to a workbook

• Add conditional formatting to cells

• Change column width and row height
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Objectives

• Check the spelling of a worksheet

• Set margins, headers and footers in

• Page Layout View

• Preview and print versions of a worksheet

• Use a Web query to get real-time data from a Web site

• Rename sheets in a workbook

• E-mail the active workbook from within Excel
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Plan Ahead

• Plan the layout of the worksheet

• Determine the necessary formulas and functions 
needed

• Identify how to format various elements of the 
worksheet

• Establish rules for conditional formatting

• Specify how the printed worksheet should appear

• Gather information regarding the needed Web 
query

• Choose names for the worksheets
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Starting Excel

• Click the Start button on the Windows Vista taskbar to display the 
Start menu

• Point to All Programs at the bottom of the left pane on the Start 
menu to display the All Programs list

• Click Microsoft Office in the All Programs list to display the 
Microsoft Office list

• Click Microsoft Office Excel to start Excel and display a blank 
worksheet in the Excel window

• If the Excel window is not maximized, click the Maximize button 
next to the Close button on its title bar to maximize the window 
click the Maximize button next to the Close button on its title bar 
to maximize the worksheet window within Excel
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Entering the Worksheet Title and Subtitle

• If necessary, Select cell A1. Type Silver 
Dollars Stock Club in the cell and then 
press the DOWN ARROW key to enter the 
worksheet title in cell A1

• Type Portfolio Summary in cell A2 and 
then press the DOWN ARROW key to enter the 
worksheet subtitle in cell A2
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Entering the Column Titles

• With cell A3 selected, type Stock and then press the 
RIGHT ARROW key

• Type Symbol in cell B3 and then press the RIGHT 
ARROW key

• In cell C3, type Date and then press ALT+ENTER. Type 
Acquired and then press the RIGHT ARROW key

• In cell D3, type Shares and then press the RIGHT 
ARROW key

• In cell E3, type Initial and then press ALT+ENTER. 
Type Price and then press ALT+ENTER Type Per 
Share and then press the RIGHT ARROW key
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Entering the Column Titles

• Type Initial in cell F3 and then press ALT+ENTER. Type Cost
and then press the RIGHT ARROW key

• In cell G3, type Current and then press ALT+ENTER. Type 
Price and then press ALT+ENTER. Type Per Share and then 
press the RIGHT ARROW key

• Type Current in cell H3 and then press ALT+ENTER. Type 
Value and then press the RIGHT ARROW key

• In cell I3, type Gain/Loss and then press the RIGHT ARROW 
key

• In cell J3, type Percent and then press ALT+ENTER. Type 
Gain/Loss
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Entering the Portfolio Summary Data

• Select cell A4, type Apple Computers, and then press the RIGHT 
ARROW key

• Type AAPL in cell B4 and then press the RIGHT ARROW key

• Type 12/1/04 in cell C4 and then press the RIGHT ARROW key

• Type 440 in cell D4 and then press the RIGHT ARROW key

• Type 64.59 in cell E4 and then click cell G4

• Type 82.99 in cell G4 and then click cell A5

• Enter the portfolio summary data in Table 2–1 for the eight 
remaining stocks in rows 5 through 12
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Entering the Portfolio Summary Data
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Entering the Row Titles

• Select cell A13. Type Totals and then press the 
DOWN ARROW key. Type Average in cell A14 
and then press the DOWN ARROW key

• Type Highest in cell A15 and then press the 
DOWN ARROW key. Type Lowest in cell A16 
and then press the ENTER key. Select cell F4
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Changing Workbook Properties and Saving 
the Workbook
• Click the Office Button, click Prepare on the Office Button menu, 

and then click Properties
• Update the document properties with your name and any other 

information required
• Click the Close button on the Properties pane
• With a USB flash drive connected to one of the computer’s USB 

ports, click the Save button on the Quick Access toolbar
• When Excel displays the Save As dialog box, type Silver 
Dollars Stock Club Portfolio Summary in the File 
name text box
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Changing Workbook Properties and 
Saving the Workbook
• If the Folders list is displayed below the Folders button, 

click the Folders button to remove the Folders list.

• If Computer is not displayed in the Favorite Links section, 
drag the top or bottom edge of the Save As dialog box 
until Computer is displayed.

• Click Computer in the Favorite Links section. If necessary, 
scroll until UDISK 2.0 (E:) appears in the list of available 
drives. Double-click UDISK 2.0 (E:) (your USB flash drive 
may have a different name and letter). Click the Save 
button in the Save As dialog box to save the workbook on 
the USB fl ash drive using the file name, Silver Dollars 
Stock Club Portfolio Summary.
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Entering a Formula Using the Keyboard

• With cell F4 selected, type =d4*e4 in the cell to 
display the formula in the formula bar and in cell 
F4 and to display colored borders around the 
cells referenced in the formula

• Press the RIGHT ARROW key twice to complete 
the arithmetic operation indicated by the 
formula, display the result, 28419.6, and to 
select cell H4
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Entering a Formula Using the Keyboard
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Entering Formulas Using Point Mode

• With cell H4 selected, type = (equal sign) to begin the 
formula and then click cell D4 to add a reference to cell 
D4 to the formula

• Type * (asterisk) and then click cell G4 to add a 
multiplication operator and reference to cell G4 to the 
formula

• Click the Enter box and then click cell I4 to select cell I4
• Type = (equal sign) and then click cell H4 to add a 

reference to cell H4 to the formula
• Type — (minus sign) and then click cell F4 to add a 

subtraction operator and reference to cell F4 to the 
formula
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Entering Formulas Using Point Mode

• Click the Enter box to enter the formula in cell I4

• Select cell J4. Type = (equal sign) and then click cell I4 to 

add a reference to cell I4 to the formula

• Type / (forward slash) and then click cell F4 to add a 
reference to cell F4 to the formula

• Click the Enter box to enter the formula in cell J4
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Entering Formulas Using Point Mode
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Copying Formulas Using the Fill Handle

• Select cell F4 and then point to the fill handle

• Drag the fill handle down through cell F12 and continue 
to hold the mouse button to select the destination 
range

• Release the mouse button to copy the formula in cell F4 
to the cells in the range F5:F12

• Select the range H4:J4 and then point to the fill handle

• Drag the fill handle down through the range H5:J12 to 
copy the three formulas =D4*G4 in cell H4, =H4-F4 in 
cell I4, and =I4/F4 in cell J4 to the range H5:J12
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Copying Formulas Using the Fill Handle
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Determining the Total Percent Gain/Loss

• Select cell J12 and then point to the fill handle

• Drag the fill handle down through cell J13 to 
copy the formula in cell J12 to cell J13
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Determining the Total Percent Gain/Loss
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Determining the Average of a Range of 
Numbers Using the Keyboard and Mouse
• Select cell D14

• Type =av in the cell to display the Formula 
AutoComplete list

• Point to the AVERAGE function name

• Double-click AVERAGE in the Formula AutoComplete list 
to select the AVERAGE function

• Select the range D4:D12 to insert the range as the 
argument to the AVERAGE function

• Click the Enter box to compute the average of the nine 
numbers in the range D4:D12 and display the result in 
cell D14
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Determining the Average of a Range of 
Numbers Using the Keyboard and Mouse

24Microsoft Office 2007: Introductory Concepts and Techniques



3/9/2010

5

Determining the Highest Number in a Range 
of Numbers Using the Insert Function Box
• Select cell D15

• Click the Insert Function box in the formula bar to 
display the Insert Function dialog box

• When Excel displays the Insert Function dialog box, click 
MAX in the Select a function list

• Click the OK button

• When Excel displays the Function Arguments dialog box, 
type d4:d12 in the Number 1 box

• Click the OK button to display the highest value in the 
range D4:D12 in cell D15
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Determining the Highest Number in a Range 
of Numbers Using the Insert Function Box
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Determining the Lowest Number in a Range 
of Numbers Using the Sum Menu
• Select cell D16
• Click the Sum button arrow on the Ribbon to display the 

Sum button menu
• Click Min to display the function =MIN(D14:D15) in the 

formula bar and in cell D16
• Click cell D4 and then drag through cell D12 to display 

the function in the formula bar and in cell D14 with the 
new range

• Click the Enter box to determine the lowest value in 
D4:D12 and display the result in the formula bar and in 
cell D14
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Determining the Lowest Number in a Range 
of Numbers Using the Sum Menu
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Copying a Range of Cells across Columns to 
an Adjacent Range Using the Fill Handle

• Select the range D14:D16

• Drag the fill handle in the lower-right corner of the 
selected range through cell J16 and continue to hold 
down the mouse button

• Release the mouse button to copy the three functions 
to the range E14:J16

• Select cell J14 and press the DELETE key to delete the 
average of the percent gain/loss
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Copying a Range of Cells across Columns to 
an Adjacent Range Using the Fill Handle
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Saving a Workbook Using the Same File Name

• Click the Save button on the Quick Access toolbar 
to save the workbook on the USB flash drive 
using the file name, Silver Dollars Stock Club 
Portfolio Summary
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Verifying a Formula Using Range Finder 

• Double-click cell J4 to activate Range Finder

• Press the ESC key to quit Range Finder and then 
select cell A18
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Verifying a Formula Using Range Finder
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Change the Workbook Theme

• Click the Page Layout tab on the Ribbon

• Click the Themes button on the Ribbon to display 
the Theme gallery

• Click Concourse in the Theme gallery to change 
the workbook theme to Concourse
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Change the Workbook Theme
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Formatting the Worksheet Titles

• Click the Home tab on the Ribbon

• Select the range A1:J1 and then click the Merge and 
Center button on the Ribbon

• Select the range A2:J2 and then click the Merge and 
Center button on the Ribbon

• Select the range A1:A2, click the Cell Styles button on 
the Ribbon, and then click the Title cell style in the Cell 
Styles gallery

• Select cell A2 and then click the Decrease Font Size 
button on the Ribbon
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Formatting the Worksheet Titles
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Changing the Background Color and Applying a Box 
Border to the Worksheet Title and Subtitle

• Select the range A1:A2 and then click the Fill 
Color button arrow on the Ribbon to display the 
Fill Color palette

• Click Turquoise Accent 1, lighter 60% (column 5, 
row 3) on the Fill Color palette to change the 
background color of cells A1 and A2 from white 
to turquoise

• Click the Borders button arrow on the Ribbon to 
display the Borders gallery
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Changing the Background Color and Applying a Box 
Border to the Worksheet Title and Subtitle

• Click the Thick Box Border command on the 
Borders gallery to display a thick box border 
around the range A1:A2

• Click cell A18 to deselect the range A1:A2
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Changing the Background Color and Applying a Box 
Border to the Worksheet Title and Subtitle
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Applying a Cell Style to the Column Headings 
and Format the Total Rows

• Select the range A3:J3

• Apply the Heading 3 cell style to the range A3:J3

• Apply the Total cell style to the range A13:J13

• Select the range A14:A16 and then click the Bold 
button on the Ribbon
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Applying a Cell Style to the Column Headings 
and Format the Total Rows
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Centering Data in Cells and Formatting Dates

• Select the range B4:B12 and then click the Center button on the 
Ribbon to center the data in the range B4:B12

• Select the range C4:C12

• Click the Format Cells Dialog Box Launcher on the Ribbon to 
display the Format Cells dialog box

• When Excel displays the Format Cells dialog box, if necessary click 
the Number tab, click Date in the Category list, and then click 
3/14/01 in the Type list to choose the format for the range C4:C12

• Click the OK button to format the dates in column C using the 
date format style, mm/dd/yy

• Select cell E4 to deselect the range C4:C13 
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Centering Data in Cells and Formatting Dates
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Applying and Accounting Style Format and 
Comma Style Format Using the Ribbon
• Select the range E4:I4
• While holding down the CTRL key, select the ranges 

F13:I13
• Click the Accounting Number Format button on the 

Ribbon to apply the Accounting style format with fixed 
dollar signs to the nonadjacent ranges E4:I4 and F13:I13

• Select the range E5:I12
• Click the Comma Style button on the Ribbon to assign 

the Comma style format to the range E5:I12
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Applying and Accounting Style Format and 
Comma Style Format Using the Ribbon
• Click cell E4

• While holding down the CTRL key, select cell G4

• Click the Increase Decimal button on the Ribbon to 
increase the number of decimal places displayed in cell 
E4 and G4

• Select the range E5:E12. While holding down the CTRL 
key, select the range G5:G12

• Click the Increase Decimal button on the Ribbon to 
increase the number of decimal places displayed in 
selected ranges
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Applying and Accounting Style Format and 
Comma Style Format Using the Ribbon
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Applying a Currency Style Format with a Floating 
Dollar Sign Using the Format Cells Dialog Box

• Select the range E14:I16 and then point to the Format 
Cells Dialog Box Launcher on the Ribbon

• Click the Format Cells: Number Dialog Box Launcher

• If necessary, click the Number tab in the Format Cells 
dialog box

• Click Currency in the Category list and then click the 
third style ($1,234.10) in the Negative numbers list 

• Click the OK button to assign the Currency style format 
with a floating dollar sign to the range E14:I16
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Applying a Currency Style Format with a Floating 
Dollar Sign Using the Format Cells Dialog Box
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Applying a Percent Style Format and Use the 
Increase Decimal Button

• Select the range J4:J16

• Click the Percent Style button on the Ribbon to 
display the numbers in column J as a rounded 
whole percent

• Click the Increase Decimal button on the Ribbon 
two times to display the numbers in column J 
with the Percent style format and two decimal 
places
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Applying a Percent Style Format and Use the 
Increase Decimal Button
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Applying Conditional Formatting 

• Select the range J4:J12

• Click the Conditional Formatting button on the Ribbon to display 
the Conditional Formatting gallery

• Click New Rule in the Conditional Formatting gallery to display the 
New Formatting Rule dialog box

• Click Format only cells that contain in the Select a Rule Type area

• In the Edit the Rule Description area, click the box arrow in the 
relational operator box (second text box) and then select less 
than

• Type 0 (zero) in the rightmost box in the Edit the Rule 
Description area
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Applying Conditional Formatting

• Click the Format button
• When Excel displays the Format Cells dialog box, click 

the Fill tab and then click the light red color in column 6, 
row 2

• Click the OK button to close the Format
• Cells dialog box and display the New Formatting Rule 

dialog box with the desired color displayed in the 
Preview box

• Click the OK button to assign the conditional format to 
the range J4:J12

• Click cell A18 to deselect the range J4:J12
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Applying Conditional Formatting
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Changing the Width of Columns

• Point to the boundary on the right side of the column A 
heading above row 1

• When the mouse pointer changes to a split double 
arrow, drag until the ScreenTip indicates Width: 14.11 
(134 pixels). Do not release  the mouse button

• Release the mouse button

• Drag through column headings B and C above row 1

• Point to the boundary on the right side of column 
heading C to cause the mouse pointer to become a split 
double arrow
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Changing the Width of Columns

• Double-click the right boundary of column heading C to 
change the width of columns B and C to best fit

• Click the column E heading above row 1

• While holding down the CTRL key, click the column G 
heading and then the column J heading above row 1 so 
that columns E, G, and J are selected

• Point to the boundary on the right side of the column J 
heading above row 1

• Drag until the ScreenTip indicates Width: 9.00 (88 
pixels). Do not release the mouse button
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Changing the Width of Columns

• Release the mouse button
• Click the column F heading above row 1 to select 

column F
• While holding down the CTRL key, click the column H 

heading and then the column heading above row 1, to 
select columns F, H, and I

• Point to the boundary on the right side of the column I 
heading above row 1

• Drag to the left until the ScreenTip indicates Width: 
12.67 (121 pixels). Do not release the mouse button
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Changing the Width of Columns

• Release the mouse button

• Point to the boundary on the right side of the 
column D heading above row 1

• Drag to the left until the ScreenTip indicates 
Width: 6.00 (61 pixels) and then release the 
mouse button to display the worksheet with the 
new column widths

• Click cell A18 to deselect columns F, H, and I 
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Changing the Width of Columns
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Changing the Heights of Rows

• Point to the boundary below row heading 3

• Drag up until the ScreenTip indicates Height: 60.00 (80 
pixels) Do not release the mouse button

• Release the mouse button

• Point to the boundary below row heading 14

• Drag down until the ScreenTip indicates Height: 26.25 
(35 pixels). Do not release the mouse button
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Changing the Heights of Rows

• Release the mouse button to change the row 
height of row 14 to 26.25

• Select cells A3:J3 and then click the Center 
button on the Ribbon to center the column 
headings

• Select cell A18
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Changing the Heights of Rows
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Checking Spelling on the Worksheet

• Click cell A3 and then type Stcok to misspell the 
word Stock.

• Click cell A1
• Click the Review tab on the Ribbon
• Click the Spelling button on the Ribbon to run the 

spell checker and display the misspelled word, Stcok, 
in the Spelling dialog box

• With the word Stock highlighted in the Suggestions 
list, click the Change button to change the 
misspelled word, Stcok, to the correct word, Stock
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Checking Spelling on the Worksheet

• If the Microsoft Office Excel dialog box is 
displayed, click the OK button

• Select cell A18

• Click the Home tab on the Ribbon

• Click the Save button on the Quick Access toolbar 
to save the workbook

64Microsoft Office 2007: Introductory Concepts and Techniques

Checking Spelling on the Worksheet
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Changing the Worksheet’s Margins, Header 
and Orientation in Page Layout View
• Click the Page Layout View button on the status 

bar to view the worksheet in Page Layout View
• Click the Page Layout tab on the Ribbon
• Click the Margins button on the Ribbon to display 

the Margins gallery
• Click Narrow in the Margins gallery to change the 

worksheet margins to the Narrow margin style
• Drag the scroll bar on the right side of the 

worksheet to the top so that row 1 of the 
worksheet is displayed
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Changing the Worksheet’s Margins, Header 
and Orientation in Page Layout View
• Click above the worksheet title in cell A1 in the Header 

area
• Type Treasurer: Juan Castillo and then press 

the ENTER key. Type 
castillo_juan37@hotmail.com to complete the 
worksheet header

• Select cell B16 to deselect the header. Click the 
Orientation button on the Ribbon to display the 
Orientation gallery

• Point to Landscape but do not click the mouse button
• Click Landscape in the Orientation gallery to change the 

worksheet’s orientation to landscape
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Changing the Worksheet’s Margins, Header 
and Orientation in Page Layout View
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Previewing and Printing a Worksheet

• Click the Office Button and then point to Print on 
the Office Button menu to display the Print 
submenu

• Click Print Preview on the Print submenu to 
display a preview of the worksheet in landscape 
orientation

• Click the Print button to display the Print dialog 
box

• Click the OK button to print the worksheet
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Previewing and Printing a Worksheet
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Printing a Section of the Worksheet

• Select the range A3:F16

• Click the Office Button and then click Print on the Office 
Button menu to display the Print dialog box

• Click Selection in the Print what area to instruct Excel to 
print only the selected range

• Click the OK button to print the selected range of the 
worksheet on the printer

• Click the Normal View button on the status bar

• Click cell A18 to deselect the range A3:F13
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Printing a Section of the Worksheet
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Displaying the Formulas in the Worksheet 
and Fit the Printout on One Page
• Press CTRL+ACCENT MARK (`)
• When Excel displays the formulas version of the 

worksheet, click the right horizontal scroll arrow until 
column J appears to display the worksheet with 
formulas

• If necessary, click the Page Layout tab on the Ribbon and 
then click the Page Setup Dialog Box Launcher to display 
the Page Setup dialog box

• If necessary, click Landscape to select it and then click 
Fit to in the Scaling area
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Displaying the Formulas in the Worksheet 
and Fit the Printout on One Page
• Click the Print button in the Page Setup dialog box to 

print the formulas in the worksheet on one page in 
landscape orientation

• When Excel displays the Print dialog box, click the OK 
button

• After viewing and printing the formulas version, press 
CTRL+ACCENT MARK (`) to instruct Excel to display the 
values version

• Click the left horizontal scroll arrow until column A 
appears
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Displaying the Formulas in the Worksheet 
and Fit the Printout on One Page
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Changing the Print Scaling Option Back to 
100%

• If necessary, click the Page Layout tab on the Ribbon and 
then click the Page Setup Dialog

• Box Launcher to display the Page Setup dialog box

• Click Adjust to in the Scaling area

• If necessary, type 100 in the Adjust to box

• Click the OK button to set the print scaling to normal

• Click the Home tab on the Ribbon
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Importing Data from a Web Source Using a 
Web Query
• With the Silver Dollars Stock Club Portfolio Summary 

workbook open, click the Sheet2 tab at the bottom of 
the window

• With cell A1 active, click the Data tab on the Ribbon, 
and then click the Existing Connections button to display 
the Existing Connections dialog box

• Double-click MSN MoneyCentral Investor Stock Quotes 
to display the Import Data dialog box

• Click the OK button
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Importing Data from a Web Source Using a 
Web Query

• When Excel displays the Enter Parameter Value 
dialog box, type the nine stock symbols aapl t 

c cmcsa goog hd ibm mrk s in the text 
box

• Click the Use this value/reference for future 
refreshes check box to select it 

• Click the OK button to retrieve the stock quotes 
and display a new worksheet with the desired 
data
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Importing Data from a Web Source Using a 
Web Query
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Changing the Worksheet Names

• Double-click the sheet tab labeled Sheet2 in the lower-
left corner of the window

• Type Real-Time Stock Quotes as the worksheet name 
and then press the ENTER key to display the new 
worksheet name on the sheet tab

• Double-click the sheet tab labeled Sheet1 in the lower-
left corner of the window

• Type Portfolio Summary as the worksheet name 
and then press the ENTER key to change the name of 
the worksheet from Sheet 1 to Portfolio Summary

• Click the Home tab on the Ribbon
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Changing the Worksheet Names
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E-mailing a Workbook from within Excel

• With the Silver Dollars Stock Club Portfolio Summary 
workbook open, click the Office Button and then click 
Send to display the Send submenu

• Click E-mail on the Send submenu

• When the e-mail Message window appears, type 
castillo_juan37@hotmail.com in the To text 
box.

• Type the message shown in the message area in Figure 
2-83 on the next slide

• Click the Send button to send the e-mail with the 
attached workbook to castillo_juan37@hotmail.com
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E-mailing a Workbook from within Excel
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Saving the Workbook and Quitting Excel

• Click the Save button on the Quick Access toolbar

• Click the Close button on the upper-right corner 
of the title bar
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Summary

• Enter formulas using the keyboard and Point 
mode

• Apply the AVERAGE, MAX, and MIN functions

• Verify a formula using Range Finder

• Apply a theme to a workbook

• Add conditional formatting to cells

• Change column width and row height
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Summary

• Check the spelling of a worksheet

• Set margins, headers and footers in

• Page Layout View

• Preview and print versions of a worksheet

• Use a Web query to get real-time data from a Web site

• Rename sheets in a workbook

• E-mail the active workbook from within Excel
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Microsoft Office 2007

Excel Chapter 2 Complete


