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INTRODUCTION 

 

I was first introduced to SmartChess in June, 1989 as a result of  a visit to the University of 

Maine by  Professor Jurg Nievergelt.  He left me with this neat tool  for viewing, analyzing, 

and writing.  However, during that time (as it  always seems) I was already inundated with all 

kinds of projects  involving relatively new software, so I wasn't too enthralled about learning 

yet another system.  Perhaps I should clarify that I feared  an excellent piece of chess software 

because I feared that I might totally wrap myself up in  it --  which while possibly facilitating 

my chess,  is not really something I am "supposed to do" -- at least not during  normal 

business hours.   

 

So SmartChess was near me for a few years and I would occasionally take a peak at it.  

However, as soon as I started to get into SmartChess and some of sample chess games that 

accompanied it, I would get fearful of the time warp which  might become involved. 

 

Little did I realize the potential for SmartChess to speed up nearly all my chess related work.  

My work as a Professor of Computer Science and International Chess Master quite often 

involves:  
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1) Viewing  chess and computer chess games.  

2) Learning  and teaching about chess and computer chess play and performance by 

collecting games. 

3)  Analyzing  games. 

4) Writing  about (communicating) chess and computer chess games and positions.  

  

Once I started using SmartChess regularly I realized what a perfect tool it was for me.  

First of all, SmartChess is an application which operates on the Macintosh.  The Macintosh 

is certainly a user friendly machine, and involves a shorter learning curve for effective use 

of applications, than other machines might,  if only due to its simple interface.   

Furthermore, SmartChess is an excellent tool for facilitating the work of the chess writer, 

analyst, player, and teacher. 
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VIEWING  

 

Naturally, as a person who loves chess, the opportunities for viewing many chess games  

quickly  via SmartChess offer immense pleasure.  There is certainly something to be said for 

the possibility of viewing many games (possibly with commentary) very rapidly.  This offers a 

revolutionary change in the way people can enjoy chess and can learn how to improve their 

game.   

 

Throughout my life I have enjoyed setting up the three dimensional wooden or plastic pieces 

and moving them as I analyze a game or position.  However the possibility of looking at large 

numbers of games quickly not only offers one the opportunity for more chess pleasure, but 

also frees up lots of time for looking at chess and chess games in different ways.   One can 

now quickly select games by Openings, Endings, players' names, players' ratings, length, 

pawn structures, etc (under the Chess -- FEATURE SEARCH menu selection).   

 

It has generally been accepted that people's success  in playing chess is largely based on the 

ability to recognize  familiar patterns and configurations of positions.  Seeing (viewing) many 

chess games can be very helpful in attaining the pattern knowledge (consciously or 

unconsciously) necessary to learn to distinguish good formations from bad ones.   
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The Standard SmartChess Game Viewing and  

Playback ICONS 

 

The icons at the top left will instantly move you anywhere around and through the game 

which has been input in SmartChess.  Clicking the Q in the => icon will present the 

game in "MOVIE MODE" so that you can sit back and enjoy the game.  The other "arrow 

headed" icons will also enable you to move around the tree of moves and variations which you 

have created.   Clicking on OVERVIEW  will let you see the game as a sequence of snapshots.  

SET OVERVIEW  controls the distribution of these snapshots enabling you to see the game 

in six major "episodes".   Any work that I have done, either in anaysis or for writing purposes 

that I may need to refer to in the future is saved under the File Submenu with the command 
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SAVE.   In any case, SmartChess won't let me  leave the system without reminding me about 

the need to SAVE  my work.    
  
GAME INFORMATION 

 

Vital information for a  game can be added as part of the GAME INFORMATION selection 

which can be found under the File Menu.  Here you can enter typical game information such 

as the place, time, date, rating, result, names, opening, etc. of the game.  All this information 

will be added to your Collection information when displayed.   To see (view) any game of a 

collection simply double click on that game in the collection window.  That will open a new 

game window.  When you are done viewing a game, simply closing the game window by 

clicking the square icon in the top left corner of your game window will take you back to your 

collection window.  
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The GAME INFORMATION WINDOW 

LEARNING   

 

I have always felt that those who genuinely love chess will naturally want to look at as 

many chess  games from top level competition as possible and review them.   That is, play 

them over, assess them  and ask questions.   In my youth, as I was a developing player, that 

is exactly what I did.  I asked questions which I posed to my cousin, who was then my 

chess mentor, and later to my chess friends.  In this way I tried to develop a general picture 

of what had transpired in the game.  That is, "Why did Black lose?  Why did the game end 

in a draw?  What did White do wrong?"   I believe that this approach led to much 

unconscious learning which I was able to later apply in play.  More importantly, it led to an 

increase in confidence with the general conclusion that all human players (even machines) 

are prone to errors which even I was able to detect at an early age. 
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In the near future via SmartChess it will be possible to view large numbers of games from 

diverse, strong, world famous  events such  as Fischer - Spassky II, 1992, Linares, 1993, 

amongst others.  From such possibilities "viewers" will be able to derive much chess 

pleasure and knowledge about the game.  The possibilities for creating GAME 

COLLECTIONS and instructional  material which is both pleasurable and enlightening are 

immense.  In my opinion the volume of material which can quickly be viewed, replayed  

and analyzed more than compensates for the missing  pleasures which may be derived from 

actually handling and moving pieces.   With SmartChess's ability to include game 

commentaries of virtually any length and to explore variations from any position, the result 

is a rich, albeit computer-based, chess experience.    

 

ANALYZING  

 

As soon as you become an "explorer"  of chess positions beyond those of the actual moves 

played in a game, you, in a sense, become an analyst.  Analysis in SmartChess is easy.   To 

create analysis, all you have to do is click in alternate moves in a given position.   The first 

move clicked in and its successors  comprise the  main line of the game, the move played.  

From any position where moves have already been created (clicked in) variations can be 

created by just clicking them in.   To leave a variation, just click your way back to the 

position where the variation began.  A very unique feature of SmartChess is the SHOW 

TREE feature found under the View Menu.   This enables the "analyst" to see all the 

variations in the game sequence in one compact view which resembles a tree.  That is,there 

are main line moves (left to right) representing the "trunk" variation and variations 

representing alternatives ("branches").   The numbers in the SHOWTREE view indicate the 

ply depth of any given position.  A ply is a half move by either side.  Most amazingly, 

clicking on  any branch in the tree on the screen will instantly bring up the position at that 

point in the game.     
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In short, I have always contended that those who enjoy viewing, replaying and analyzing 

chess games are those who are bound to succeed.   Furthermore, it is my belief that success in 

almost any competitive activity has three essential ingredients:  motivation, practice, and 

observation all blended with a little talent.   In this context SmartChess offers the serious 

student excellent possibilities in each of the above three regards.  Certainly one can observe, 

one can practice by analyzing moves and variations,  and finally the motivation for success 

can be driven by considering and reviewing the methods of those who have been successful.     

 

 
SmartChess as an excellent tool for doing and writing up analysis of alternatives.   Here 38. 

...Qh4? was the move played, while 38. ...Qh5! should have been played. Clicking on this 

move leads to an analysis of moves.  
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Converted to Rich Text Format (RTF) this analysis with continuations and a little editing 

produces:  38.… Qh5! 39.Kg1 (not 39.fxg4?? Qh1+ 40.Kf2 Bh4 mate) gxf3 40.Qh2 f2+ 41.Qxf2 



Qg4+ 42.Qg2 (another potential error is 42.Kh1?!  Bh4 43.Qg2? (better 43.Qf1)  Qd1+ 44.Kh2 

Bg3+ 45.Kh3 Qh5+ mate) Qd1+ 43.Kh2 f3 (if 43....Bh4 44.Qxc6+ should be winning for White) 

44.Qf2 Qe2 45.Kg1 Qxd3 46.Qe3+ and White is winning.  However, as readers can see, the 

variations are like a minefield.  

 
The analysis given above in the longest variation leading to 45.Kg1 as represented 

in the Tree Window as a result of clicking SHOW TREE.  Any position and 

continuation can be viewed by clicking on a line in the Tree Window.  

The game concluded:  39.Qg2 g3  40.q6 Kg6  41.a7 Qh8 42.Nb6 Qd8 43.Qe2 Qh8 

44.Kg1 Bd8 45.Nc8  Black Resigns.  
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With the SELF-TEST feature you can compare your own move selections with those 

played by masters or analyzed by annotators.   

 

Open a 'master' game, then enable Self-Test mode by clicking on the small lock in the 

upper left-hand corner of the game window (SmartChess now hides all subsequent moves).  

Play the move you think is the best, and -- if you guessed the right move - continue with 

the next move (you have three chances to get the right move before SmartChess goes 

automatically to the next move).  with SELF-TEST from the VIEW menu, you can see a 

statistic about your performance. 

 

WRITING  

The mechanisms and possibilities for writing about chess have been widely expanded for 

me via SmartChess.  Prior to 1980, I would develop a concept for a chess article by writing 

the score and comments by hand on paper while I played through the moves on the board.  

Then I would go through another "pass" through the moves and notes as I typed them up.  

Finally, I would make another pass through the moves  and commentary to proofread it for 

final corrections.  In later years (around 1980)  I would type the commentary in on a 

wordprocessor as I played through the moves on a  mid-sized chess set.   Then I would go 

through at least one more pass with the article to check for the correctness of my notes and 

score.s   
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SmartChess is an excellent tool for the chess writer.  

 

With SmartChess I am able to develop my articles directly from the score of the game.  The 

program will also check that the score of my input moves (long or short algebraic, in 

several possible languages)  is correct.   All I need to do is click, click, click.   Thus 

developing an article simply entails clicking in the moves and adding my commentary and 

variations just as I click in the moves which are depicted in a Diagram Window.  The 

window is beautiful and clear and just about compensates for the inability to "hold and 

move" my three dimensional pieces on a three dimensional board.  There is no restriction on 

the length of my commentary for every move or position.  Variations from a given board 

are just created by clicking them in.  To make annotations for moves like "!", "?", "!?" I 

don't have to go to hidden windows.  All the icons for annotations are right there in front of 

me on the screen.   To produce a diagram of a given position I don't have to access other 
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programs; all I need to is click "COPY DIAGRAM"  from the Edit Menu and a diagram 

is created for the current board position.   

 

Hence my standard sequence of operational steps for writing an article is:   

 

 1)  NEW GAME  under the File Menu. 

2)  Choose PREFERENCES from the Edit Menu and then I am ready to make the 

appropriate choices.  

 Note that these PREFERENCES will normally only need to be set once in the 

activity of writing an article.   

 3)   Click in the moves of the game with comments.   

 [If for some reason I (or the program) notice errors in the input score I either 

"take a move back" (if I notice the error immediately) or go to the Tree Menu 

where I can INSERT MOVE or INSERT MOVE PAIR (for a  move by 

White and Black or Black and White) or I can  delete erroneous  moves via 

DELETE NODE option under the Tree Menu, and then  select the appropriate 

action from the choices suitable for my situation] 

4) When I have done some significant work then I choose SAVE under the File 

Menu and name the file appropriately to make sure that my work is saved.   

 

5) The next step is to send the game with notes to Microsoft Word for final 

grooming and editing.  This is accomplished with the command WRITE AS 

TEXT under the File Menu.  After choosing the appropriate settings (such as 

number of columns, font sizes, etc.)  I select WRITE in the open dialog 

window.   This produces a RTF (Rich Text Format) file which I am now able to 

open, read, and edit  in Microsoft Word.   When the prompt appears the RTF 

file now only needs to be SAVED under a new name (I usually give the 

extension to filename RTF, e.g. filename/RTF ). 
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Using the steps prescribed on the previous page, SmartChess can be used to quickly 

develop annotated games for articles like the following in RTF. 
 
Example 23: (from THE CONDITIONS AND 
METHODS FOR ATTACKING THE KING) 
(Blumenfeld & Kopec, 1993) 
Kasparov - Gelfand  Linares, 1993  Rd 11 
The following example is one that stands all by 
itself -- it does not involve a rook lift, or a pawn 
on e5, or a king caught in the center.  It simply 
represents great strength and the mounting of 
forces around the castled king with a lead in 
development leading to a decisive attack. The ease 
with which Kasparov disposes a player amongst 
the top five rated in the  world, Boris Gelfand 
(2690), helps explain why the World Champion 
seems to be in a league of his  own. 
1 e4  c5  
2 Nf3  d6  
3 d4  cxd4  
4 Nxd4  Nf6  
5 Nc3  a6  
6 Bc4  e6  
7 Bb3  b5  
8 0-0  Be7  
9 Qf3 
This move was made popular by Soltis in the 1970's 
against the Najdorf.  Nonetheless, with some care, 
the whole line was considered rather harmless for 
Black. 
  9 … Qc7  
 10 Qg3  0-0  
 11 Bh6  Ne8  
 12 Rad1  Bd7 
All these moves follow Sokolov-Gelfand (USSR CH, 
1989) with a slight advantage for White after 13.f3.  
Instead Kasparov finds a move which seems 
deceptively simple but gives White a continuing 
attack on the Black K. 
 13 Nf3! 
In just 12 moves Black will be forced to resign! 
  13  …  b4  
 14 Ne2  a5 
On 14. ...Bb5 White could play the same reply: 
15.Nf4!. e.g. Bxf1 16.Bxg7! with a crushing attack. 

15 Nf4! 
White now threatens Bxg7 anyway.  All four of 
White's minor pieces, his Q, and QR are all 
participating in the attack. 
 15 … Kh8  

 16 Bg5   
If now 16. ...f6 White can win with either 17.Bxe6 or 
17.Qh3 (or even Nh4). 
With 17. Qh3 the line could go fxg5  18.Ng6+ Kg8 
19.Bxe6+ Bxe6 20.Qxe6+ Rf7  21.Nxg5!! which is 
decisive.  Or with 17.Bxe6 the threat is Ng6+.  A 
continuation could go: 17.… Bxe6 18.Nxe6 Qc8 
19.Nxf8 fxg5 20.Nxg5 and White has a winning 
advantage. e.g. 20. ...Bxf8 21.Nf7+ and 22.Qb3 with 
deadly threats or 20.… Bxg5 21.Qxg5 Nf6 22.Rxd6 
Qxf8 23.e5 And White is winning.  
 16 ... Nf6  
 17 Qh4!  
Another very strong move menacing Nh5.  
 17. ... Bb5   
 18. Nd4! 

 
The series of hammer blows continues.  If now Bxf1 
19.Ndxe6 fxe6 20.Bxe6 with the threat of Ng6+ is 
decisive.  
 18 .…  Be8 
You cannot lose several tempi (e.g. Bd7-Bb5-Be8) 
and not complete your development (N/b8) against 
a player of Kasparov's attacking ability (of whom 
there are few) and hope to come out alive White's 
K-side threats are too strong for Black to be able to 
effect his only threat of a5-a4.  
 19. Ndxe6  

Kasparov finds a forceful and creative way to exploit 
the weakness of the e6 square and Black's back rank.  
 19 .…  fxe6   
 20 Nxe6  Qa7  
 21 e5  dxe5  
 22 Nxf8 Bxf8 
 23 Bxf6 gxf6  
 24 Rd8  
If 24...Qe7 25.Qc4 wins instantly.  
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 24.   … Nd7  
 25 Qg4  Black Resigns.  
On 25. ...Bg7 26.Qe6.  

  
   
 

BOARD SETUP 

Instead of writing about a complete game, if  I need to write about an individual position, or 

set of positions, all I need to do is choose NEW GAME under the File Menu and then 

BOARD SETUP  under the Chess Menu.   I  CLEAR the board if the position is near an 

ending.   Then I  click and drag each piece to its desirable destination square, clicking on 

squares which should be empty.  Finally I  chose  the appropriate settings from the dialog 

options (such as castling options for each side, whether en passant possible in the position 

being set up, side to move , and move number).  When I am done I SAVE my position with its 

moves and comments. 

 
The SmartChess Board Setup Dialog Box 
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GAME COLLECTIONS   

 

An important "complement" to the standard SmartChess features for Viewing, Analyzing, and 

Writing about chess is the ability to create and view/replay GAME COLLECTIONS.  This 

feature enables one to view a group of games as a package or collection.  You can create or 

receive such a collection of games annotated or unannotated.   There are many notions of 

different kinds of collections which will be of interest to the chess enthusiast or student.   

These include collections of the games of famous players, collections of tournaments, 

collections of Openings, collections  of events which may bring together a group of seemingly 

unrelated individuals, or simply collections of one's own games.  Such collections are easy to 

create with commentaries.   

 

A game collection can be quickly created by selecting SHOW COLLECTION under the 

View Menu.  More games can be added to an existing collection by chosing ADD NEW 

GAME under the File Menu.  

 

Now that you have learned to work with a single game it is useful to know that a game is 

simply a special case of a collection consisting of just that one game.  For convenience and 

economy of memory you will want to collect up to a few dozen related games into a collection 

(i.e. a single file).   

 

In my own case, with three household moves in recent years, the time often spent  searching 

for certain games I have played  in  certain tournaments, games against certain opponents,  or 

games with certain openings,  led me to the conclusion that the possibility of creating  

computer-based collections of my own games was very intriguing and promising.    I am 

presently in the process of transferring some 700 games from loose scoresheets or scorebooks 

which are becoming illegible to the finer impressions of SmartChess which can be reproduced 

in many forms.   
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It often arises that students want to see how I handle a particular opening variation, e.g. the 

English Opening.   Having input  my  games as collections I am able to select all those which 

are English Openings with me as Black (by their Opening Key) or I can quickly find games by 

events, opponent's names, dates, etc.  

A TYPICAL COLLECTION WINDOW FROM THE  1993 BIEL INTERZONAL. 

 

ATTACHING INFORMATOR KEYS  

A game or collection of games can be classified according to the International standard of 

keys (codes) for chess openings developed in Yugoslavia (known as Informator Keys) by the 

following sequence of steps: 
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1) Open the Informator Key file. 

2)  Select INSTALL AS KEY from the Tree Menu. 

3) Close the Informator Key game window. 

4) Open the game or Collection  you wish to Classify. 

5) Under  the Edit Menu chose SELECT ALL. 

6) Now select CLASSIFY  from the Tree Menu. 

7) After a few seconds the games are classified according to the international Informator Keys 

(classifications) typically  

 A0, A1, A2, ... B0, B1, B2, ... C0, C1, C2, etc.  

8) Now the game or collection can be closed and SAVED with keys included in the GAME 

INFORMATION. 
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  A FISCHER SELECTION WITH KEYS ATTACHED. 

 

IMPORTING  

 

SmartChess has been developed as a versatile system which can read data created in a number 

of standard formats including ChessBase, NicBase, ASCII (text) and SmartChess format itself.   

 

Let us say a chess game score is available in algebraic notation (long or short).  All that you 

need to do is copy this game score as text (usually COPY under the Edit Menu of most 

Macintosh word processors) .   Then all you need to do to read the game into SmartChess is: 

1) Open a new game in SmartChess with just the initial position and 
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2) Select COPY TREE   under the Edit Menu and the game becomes a SmartChess file 

which you can play through, modify, comment on, etc.   

 

To ensure that the Importing process works, make sure that you delete any "headers" at the 

beginning of your ASCII game score.  That is, just provide the "pure" chess moves  of a chess 

game score in algebraic notation without any player's names, tournament information, etc., 

although move numbers and dots after White moves (e.g. 17.b4) may be included.  

 

If a single game score is available as text in  another format (ChessBase, NICBASE, ASCII, 

etc.) it can be read into (imported) to SmartChess by the following steps: 

 

1) Open SmartChess. 

 

2) Chose NEW or OPEN a particular game or Collection under the File Menu.  If you chose 

NEW or are opening an existing game, then chose SHOW COLLECTION under the 

View Menu.   

 

3) Now select IMPORT/EXPORT under the Chess Menu. Chose the format from which 

you wish to import the game 

(SCB , Standard text, ChessBase text , NICBase text, PGN (Portable Game Notation) 

or 4M  are the choices for formats).   Then select the format you are importing and in the 

dialog box which follows, indicate the file you want to import into SmartChess.  If the 

import process worked then the file should be readable as a SmartChess file which you are 

able to view in the Game Collection Window.  

 

EXPORTING  

Gamescores in SmartChess format can also be easily exported for reading and use in other 

formats.  The easiest way is to use the WRITE AS TEXT option under the File Menu if all 

you need to do is produce a complete ASCII (text) game score.    
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CREDITS 

The Smart Game Board, the main viewing platform and interface for SmartChess, was 

developed by Anders Kierulf.  Christoph Wirth is the main designer and implementor of 

SmartChess.   The SmartChess Consortium (SCC) is header by Professor Jurg Nievergelt.  

Fide Master Fabian Maeser has made important contributions to the development of 

SmartChess.  
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